In order to connect to databases you need to click on File -> Import Data -> SQL
database.

Configure MS-ACCESS and Import MS-ACCESS data into BlueSky Statistics

Requirements:

BlueSky Satistics Uses R Requires DSN (ODBC drivers)
64-bit 64-bit 64-bit
32-bit 32-bit 32-bit

Table: 1

Example : BlueSky Statistics 64-bit application will use R 64-bit. And R 64-bit will only be able to use 64-
bit MS-ACCESS DSN(Data Source Name).

Step 1. Determine whether you need to install 32/64 bit MS-Access Database
Engine:

You Have BlueSky | You Need Install This
Statistics

MS-ACCESS (32-bit) | 64-bit You need 64-bit Access Drivers to AccessDatabaseEngine_x64.exe
create 64-bit ODBC Data Source
Name (in step 2 of “Creating Data
Source Name (DSN) in Windows”
section below).

32-bit You should already have drivers for | Not applicable
32-bit to create 32-bit ODBC Data
Source Name(go to step 2)

MS-ACCESS (64-bit) | 32-bit You need 32-bit Access Drivers to | AccessDatabaseEngine.exe
create 32 bit ODBC Data Source
Name(in step 2 of “Creating Data
Source Name (DSN) in Windows”
section below).

64-bit You should already have drivers for | Not applicable
64-bit to create 64-bit ODBC Data
Source Name(go to step 2)

Table: 2

Visit following link and download “Microsoft Access Database Engine 2010 Redistributable”. It has both
32-bit and 64-bit drivers. Check the table above and see which one you require.

http://www.microsoft.com/downloads/en/details.aspx?familyid=C06B8369-60DD-4B64-A44B-
84B371EDE16D&displaylang=en.



http://www.microsoft.com/downloads/en/details.aspx?familyid=C06B8369-60DD-4B64-A44B-84B371EDE16D&displaylang=en
http://www.microsoft.com/downloads/en/details.aspx?familyid=C06B8369-60DD-4B64-A44B-84B371EDE16D&displaylang=en

Suppose you need to install AccessDatabaseEngine_x64.exe: Open a Command prompt (in a directory
location where you have your downloaded files) and type the following command:

AccessDatabaseEngine_x64.exe /passive

. Administrator; Command Prompt - B

icrosoft Windows [Version 6.3.96001]
tc» 2013 Microsoft Corporation. All rights reserved.

SSUIHDOWSssystemd2 Fod
:s2>ed MyDownloads

:sMyDownloads *AccessDatabaseEngine_x64.exe spassive

Installing by double clicking that file may result in an error. So it is better use Command prompt with
/passive option to avoid install errors.



Step 2. Creating Data Source Name (DSN) in Windows:

1. Open “Control Panel” in Windows. Click open “Administrative Tools”

2] All Control Panel ltems = B

+ @ » Control Panel » All Control Panel ltems » v & Search Control Panel o

Adjust your computer's settings View by: Large icons ¥

:E‘Id features to Windows ‘: Administrative Tools

AutoPlay d Button @fl Colour Management
L

Action Center

Credential Manager

" Date and Time @ Default Programs

QéNG ez ¥

Device Manager g Devices and Printers Display
Ease of Access Center % Family Safety :‘{‘D File History
Flash Player (32-bit) l Folder Options Fonts
HomeGroup g@ Indexing Options % Intel(R) HD Graphics
. . -
!I'nc;[r::s PROSet/Wireless Internet Options éﬂ, Java
= (= . .
<Z» Keyboard %— Language |D;]‘ Location Settings v




2. In “Administrative Tools” window you should see “ODBC Data Source (32-bit)” and “ODBC Data
Source (64-bit)”. You can create 32-bit Data Source Name using “ODBC Data Source (32-bit)” and
64-bit DSN using “ODBC Data Source (64-bit)”. Please refer to table 2, to determine whether
you need 32 or 64-bit ODBC Data Source Name.
However in our example we will create 64-bit DSN (steps for creating a 32-bit DSN are similar).
So we will click open “ODBC Data Source (64-bit)”.

- oI

N 4 = | Shorteut Tools | Application Tools Administrative Tools
Home Share View Manage Manage : 9
e % cut k ‘lé x ; New item ) B Open -~ BH Selectall
[i] Copy path : o —I‘:'lEasy access - - Edit Select none
Copy Fests 2] Paste shortcut h:::\:e igpvy DEIvEtE Rename frjll—l-:l Pmpfrties o History 5 Invert selection
Clipboard Organise MNew Open Select
1 ¢ Control Panel ¢ All Control Panel ltems ¢ Administrative Tools v & Search Administrative Tools o
A Anil Dabral ~ éf, Compenent Services (28 Windows PowerShell ISE
18 This PC [# Computer Management
i Desktop [#l Defragment and Optimise Drives
| Decuments (75, Disk Clean-up
& Downloads (] Event Viewer
' Music fak, iSCSl Initiator
= Pictures |ODBC Data Sources (32-bit)
& Videos |ODBC Data Sources (64-hit)
i Local Disk (C) (&) Performance Menitor
a Workspace (D) (&) Resource Monitor
o DVD RW Drive (E) [#), Services
-;:i Libraries (71 System Configuration
€l Network (& System Information
8 Control Panel (7) Task Scheduler
@ All Control Panel ltems @Windows Firewall with Advanced Security
¥ Action Center [#8] Windows Memory Diagnestic
Administrative Tools (3 Windows PowerShell (x86)
E {lUtUlP'a?‘. 3 v @'Windows PowerShell ISE (x86)
19items 2 items selected 2.22 KB B =




3. Following window will appear when you click open “ODBC Data Source (64-bit)”. In this window
you need to be on “User DSN” tab. Now click on “Add” button to create a new User DSN (64-

bit).

e ODBC Data Source Administrator (64-bit) H

User DSN | System DSN | File DSN | Drivers | Tracing | Connection Pocling | About |

User Data Sources:

MName Platform  Diriver Add..
dBASE Files J32/6d-bit  Microsoft Access dBASE Driver (".dbf, “ndx, =1
Excel Files J32/64-bt  Microsoft Bxcel Driver ("xds, “xdsx, “xdsm, ~xsh Remove

MS Access Database 32/64bit  Microsoft Access Driver ("mdb, *.accdb)
Configure...

~. An QODBC User data source stores information about how to connect to the indicated data provider. A
; IJser data source is only visible to you and can only be used on this computer.

OK || Cancel Apply Help




Following window will appear. In this window you need to select “Microsoft Access Driver (*.mdb,
*.accdb)”. If you do not see this item in your list, that means you do not have Access driver installed for
64-bit DSN. You need to follow the instructions provided in the “Determine whether you need to install

32/64 bit MS-Access Database Engine” section above.

= ODEBEC Data Source Administrator (64-bit)
Create New Data Source H
Select a driver for which you want to set up a data source. ;:Id
Mame ers
Microsoft Access dBASE Driver (*.dbf, ndbe, *mase) 140/ | o0
Microsoft Access Driver (".mdb, * accdb) 14.0 I
Microsoft Access Text Driver (“bd, = csv) 1400 |9
Microsoft Bxcel Driver (" xds, “xdsx, “xdsm, *xdsh) 140
ODBC Driver 11 for SGL Server 201«
SGL Server 5.03
SGL Server MNative Client 11.0 201°
£ >
3 provider. A

< Back Cancel

0K [T Canecel | Apphy Help




4. After selecting “Microsoft Access Driver (*.mdb, *.accdb)”, click on “Finish” button. You will get
following window.

System Database...




5. In this window you need to provide Data Source Name of your choice. Then click on the “Select”
button to locate your Microsoft Access file (*.mdb or *.accdb). If you want to assign a User ID
and Password (this is not common), then click on the “Advanced” button. Finally click “OK”.

"E.‘ e TSk i : - | . " Y P, I S
ODEBC Microsoft Access Setup ?
ser DS
Data Source Name: | MyAccessDSNGS QK
Uszer D
Description:
Mame Cancel
Database
bskoyo
bekoyc Database: D \Morthwind 2007 sample accdb Help
dBAS )
Select... Create. .. Repair... Compact...
Excel _ Advanced. ..
MS A

System Database

(®) None

< i) Database:

System Database. ..

Options=> r. A
=

QK Cancel Apply Help




6. Inthe “ODBC Data Source Administration (64-bit)” window below, you will see your DSN that
you just created. Now you are ready to use your DSN with the BlueSky Statistics application to
load the data from your Access database which is referenced by your DSN.

= ODEBC Data Source Administrator (64-bit) H

User DSN | System DSN | File DSN | Drivers | Tracing | Connection Pooling | About |

User Data Sources:

MName Platform
dBASE Files J2/64-bit
Excel Files 32/64-bit

M5 Access Database 32/64-bit
MyAccessDSMNES 32/64-bit

Drriver Add...
Microsoft Access dBASE Driver (".dbf, “ndw, “r

Microsoft Excel Driver (“xs, “xsx, *xlsm, *dsb Remove
Microsoft Access Driver (" mdb, ~accdb)

Microsoft Access Driver ("mdb, * accdb) Corfigure...

=

. An ODBC User data source stores information about how to connect to the indicated data provider. A
: |User data sounce is anby visible to you and can only be used on this computer.

OK || Cancel | foply Help




Now from BlueSky Statistics application go to File -> Import Data... -> SQL Database a window
will appear as shown below. First select “MS-ACCESS” from the list. Now you need to fill in the
name of your DSN (this is the name of the DSN you just created and optionally the

user/password. In our example we do not have user id and password so we leave those fields
blank. Now click “Connect”.

Data Source Selector Window H

Select Data Source:

MSSOL
Postgred0L
Cracle
MySQL
SCLite
MS-ACCESS

Specify Connection Parameters:

Data Source Name: | MyAccessDENG4

User |D:

Paszward:

Cancel Connect




8. Ifall the fields are correctly filled, clicking “Connect” will pop open following window. In this
window first you need to “Select a database” from drop down. Then you can click on “Tables”
“Views” checkboxes depending on your choice, what you want to see in the list box below, on

the left. Once the Table/Views list box is filled with Table/View names, you can click any one of
those to see its column names in the list box, on the right. Finally, in the text box below, you can
write your select query or sub query with join etc. and the results of the query will be loaded in
the data grid of the BlueSky Statistics application.

[ Table and Column(s) Selector Window

Select a database: | MyAccessDSNG4

Check Tables/Views to see the list of Tables/Views, Click cn
the tablefview name to see its columns on the nght pane

Tables [ ] Views

TablesViews:

MSysCueries -
MSysRelationships
Customers

Employee Privileges
Employees

Inventary Transaction Types
Inventary Transactions
Invaices

Crder Details

Crder Details Status

Crders

Mirdare Chateic

-

Displays the columns of the selected table,

Columns;

D -
Campany

Last Mame

First Mame

E-mail Address

lob Title

Business Phone

Home Phone

Mabile Phone

Fax Mumber

Address

-

Write your "SELECT' query in the textbox below, You can enter complex queries, sub-queries, joins as supported by your SGL

SEMVET.

1. MS-50L Example:
2. MySQL / Postgres / M3-ACCESS Example:

SELECT * FROM Owner.TABLE-MNAME

SELECT * FROM TABLE-MNAME

select * from Customers

| Back | | oK |

9. Click ‘OK’ to load the result of select query in the BlueSky Statistics grid.




Configure Microsoft-SQL Server (MS-SQL server) and Import MS-SQL data into
BlueSky Statistics

To import data from Microsoft-SQL server you must have Microsoft SQL Server JDBC driver installed on
your system. You can download this driver from Microsoft’s website (https://www.microsoft.com/en-
us/download/details.aspx?id=55539). It has been found the matching Java version is necessary for the
JDBC driver to work properly. Please check ‘System Requirements’ and ‘Install Instructions’ sections on
the download page carefully. By default it installs to ‘C:/Program Files’. Do not install it in any other
location.

Other requirements:

1) RIDBC R package must be present. For this you can execute a dialog from the BlueSky Statistics
application ( go to Installation = Install All required R package from CRAN ).

2) Install Java and set JAVA_HOME environment variable to point to Java install location (eg.
C:\Program Files\Java\jdk1.8.0 112)

3) Using SQL server agent make sure that SQL server browser is running.

From BlueSky Statistics application, go to Options -> Configuration Settings now switch to SQL settings
tab. Enter MSSQL server instance name . Also specify the path to the driver jar file. The path must
defined using forward slashes, as shown below.

By, Options Window
Path Settings | Colors | Image | Default Packages | User Packages | Advanced | Others | 50U Settings | PDF Settings | Models

MSSQL Server Instance Enter server instance name :
MSSQLSERVER
Please madify the server instance name if its different from the default
Default instance name for M53QL Full is MSSQLSERVER and for MS5QL Express is SOLEXPRESS

Mi ft SOL server Driv th:
icosoft SQL server Driver pa C:/Program Files/Microsaft SQL Server JDBC Driver 3.0/sgljdbc_3.0/enu/sgljdbcd.jar

Example: C:/Program Files/Microsoft SQL Server IDBC Driver 3.0/sqgljdbc_3.0/enu/sqljdbed.jar
MNOTE: You must use forward slash{/) in path.

|Can<:e|‘ ‘Default‘ ‘ Apply |

To connect to a remote MS-SQL server that is maintained by your admin, you need to get the SQL server
name (‘host’ address), user id and password from the admin.

1. From BlueSky Statistics main window, click File -> Import Data... -> SQL Database. Following
window will pop open. Select MSSQL from the list by clicking on it. Enter SQL server name, user
id and password.



Select Data Source:

PastgreSQL
Cracle
MyS0L
SQ0Lite
MS-ACCESS

Specify Connection Parameters:

Haost / Server: localhost

User |D:

Pazzward: Il




Click “Connect” button and you will see following window. In this window you need to select a
database name from the dropdown and then based on choice you can check “Table” and/or
“Views” checkbox to see tables and/or views in the list box below, on the left. If you click any
table or view name in the left table, you will see its column names in the list box, on the right.
Finally, in the text box below, you can write your select query or sub query with join etc. and the
results of the query will be loaded in the data grid of the BlueSky Statistics application.

[ Table and Column(s) Selector Window “
Select a database: | AdventureWorks2014 -
Check Tables/Views to see the list of Tables/Views. Click on Displays the columns of the selected table.

the tablefview name to see its columns on the right pane

TakblesVisws: Tables [] Views Columns:

T A T T TR S TS T T ST ST Ty

Production.ProductSubcategory BusinessEntitylD

Person.BusinessEntityAddress AccountNumber

Purchasing.ProductVendor Name

Person BusinessEntityContact CreditRating

Praduction.UnitMeasure PreferredVendorStatus

Purchasing.Vendor u ActiveFlag

Person.ContactType PurchasingWebServiceURL
Modified Date

Sales.CountryRegionCurrency
Person.CountryRegion
Production.WorkOrder

Purchasing.PurchaseCrderDetail

Write your 'SELECT' query in the textbox below. You can enter complex gueries, sub-gueries, joins as supported by your SCL
server.

1. M5-50L Example: SELECT * FROM Owner.TABLE-MAME
2. MySQL / Postgres / MS-ACCESS Example: SELECT * FROM TABLE-MNAME

select * from Purchasing.Vendor

|Back|‘DK‘

3. Click ‘OK’ to load the result of select query in the BlueSky Statistics grid.

Troubleshooting Connection issues



1) If you see TCP/IP related error like following and follow the steps to resolve it.

Errors/Warnings:

% Error
! User Msg: "ConnectSQL: Error connecting to: MS50L"

R EmrMsg: com.microsoft.sqlserverjdbc.SOLServerException: The
server MSS0LSERVER is not configured to listen with TCP/IP. in
function: .jcall{dre@jdre, ‘Ljava/sql/Connection;’, 'connect’,
as.character(url)[1], p) which is possibly called from function:
ConnectS0L( databasename=c(" ), mssqldrvjdbcpath=c('C:/Program
Files/Microsoft JDEC Driver 4.0 for SOL
Server/=qljdbc_4.0/enu/sqljdbed.jar' ), pass="""""", query=c(" },
serveraddress=c(' jdbcsglserver//localhost\MS5CQLSERVER' ),
servertype=c('MSS0L" ), usr=c('sa' } )

Error

User Msg: "Get50l Databases: Error getting databasenames : "

R Err Msg : object 'BSkyS0Lconn’ not found in function:

GetSOl Databases( databasename=c(" ),
mssgldrvjdbepath=c('C:/Program FiIesfMicmsuft _IDEC Driver 4.0 for
SOL Server/sqljdbc_4.0/enu/sqljdbed.jar' ), pass="""""

serveraddress=c( jdbc: sqlsen.rer".."flocaIhost\MSE‘r[lLSERVEH' L
servertype=c('MSS0L" ), usr=c('sa' } )

To fix above issue please follow these steps:
a) Open ‘Sql Server Configuration Manager’ and locate ‘Protocols for MSSQLSERVER’.
Where MSSQLSERVER is an instance name (you may have a different instance



name).

= Sql Server Configuration Manager - o IEl
File | Action View Help

L L IEERERESE 7

‘@ S0L Server Configuration Manager (Local) Protocol Name Status
5 F"u:: gerl.fer ;Emcei Conf S % Shared Memory  Enabled
E_ S0L Server Metwork Configuration (32bit “ Named Pipes Dicabled

» 2b 501 Mative Client 11.0 Configuration (32t _ <J1:|
5 TCP/IP Disabled
4 _E_ S0OL Server Network Configuration ¥ 4 sanie
2= Protocols for MSSOLSERVER |
[» % S0L Mative Client 11.0 figuration

MSSQLSERVER is an instance name. You

may have a different instance name hgre.
< >

b) On the right panel if ‘TCP/IP’ is disabled, right click on ‘TCP/IP’ and choose ‘Enable’
from the popup menu.
= Sql Server Configuration Manager = =
File Action View Help

=z EB=H

‘g SCL Server Configuration Manager (Local) Protocol Name Status

5| Eﬂt :emer :fmceic . S %~ Shared Memory Enabled
H s0L Server Network Configuration (32bit %= Named Pipes Disabled

> @ S0L Mative Client 11.0 Configuration (321

4 H 50L Server Network Configuration . e | Enable
Et: Protocols for MSSOLSERVER Disable
[» % S0L Mative Client 11.0 Configuration
Properties
Right click on TCP/IP Help
and click on 'Enable’

from the popup menu.

< >

Enable selected protocol.




c) You will see a warning message. Click OK.

Warning

'“-I Any changes made will be saved; however, they will not take effect until
¥ the service is stopped and restarted.

d) Now we need to restart the Sql server. In ‘Sql Server Configuration Manager’ select
‘SQL Server Services’ from the left panel.

e)

File
&= |7 c=H

Action  View Help

Sgl Server Configuration Manager

—

- B SOl Native

Select SQL Server
Services

ent 11.0 Configuration

‘E 50L Server Configuration Manager (Local) Mame
] SQLServer Services| || B SQL Server (MSSQLSERVER)
_E_ S0L Server ork Configuration (32bit ﬁ SOL Server Browser
5 .. 50L Mative Chent 11.0 Configuration (321 2 SQL Server Agent (MS
4 E_ S0L Servgr Metwork Configuration d
B~ Protogols for MSSQLSERVER

R..

Stop and start 'SQL Server (MSSQLSERVER)'.
Here MSSQLSERVER is instance name. You
may have a different instance name.

State

Running
Running
Stopped

From the right panel, right click ‘SQL Server (MSSQLSERVER)’ and select ‘Stop’ from

the popup menu.



= Sql Server Configuration Manager - o IEl
File Action View Help

L AR-RENEYN ? JRORCRONC,

‘@ 50L Server Configuration Manager (Local) Mame Ciate
B SQLServerServices) BT sa server (MssQLSERVER
_E_ S0L Server Metwork Cenfiguration (32bit ﬁ SOL Server Bfwser Start
[ % S0L Mative Client 11.0 Configuration (321 Stop
= LS Agent (MS50LS
4 _E_ 50L Server Metwork Configuration BSSQL Server (M35Q Pause
Et: Protocols for MSSOLSERVER R
EsUME
» 2} 50l Native Client 11.0 Configuration
Restart

Right click on "SQJl Server(MSSQLSERVER)'
and click 'Stop’ friom the popup menu. Properties
MSESQLSERVER is gn instance name. You

Help
may have a differgnt instance name.

b4 > ([ £ >

Stop selected service.

f) Right click ‘SQL Server (MSSQLSERVER)’ again and select ‘Start’ from the popup
menu.

= Sqgl Server Configuration Manager ==
File Action View Help

L AR-RNENER] 7 RRORONOR:

‘@ S0L Server Configuration Manager (Local) Mame State
E ﬁt :ewer ;Emcei Confiquration (32bit SNS0L Server (MSSQLSERVER)  Stopped
=N erver Metwork Configuration it .
» Eb SOL Native Client 11.0 Configuration (321 %Ek :ewer irowrie.(rwI A :.:lnmn: i:arl
erver Agen .. Stoppe
4 E_ SQL Server Network Configuration g PP °p
B Protocols for MSSOLSERVER Pause
[ @ S0L Mative Client 11.0 Configuration Resume
Right click and choose =L
'Start’ from the popup Properties
menu.
Help
< >« >
Start selected service.

Configure PostgreSQL and Import PostgreSQL data into BlueSky Statistics



To get PostgreSQL “host” address, user id, password and database name, you need to contact your
PostgreSQL server admin.

1. Steps for connecting to PostgreSQL are similar to MS-SQL. Except you need to specify database
name in ‘Database Name’ field.

Select Data Source:

MSSQL

[ PostgreSCL
Oracle
MySQL
SQLite
MS-ACCESS

Specify Connection Parameters:

Host / Server: bs-post.ocqdjdcksngous-west-2.rds.amaz

User ID: sUperuser

Passward: TIIIIIIIIL}

Database Name: posigres




Click “Connect” button and you will see following window. In this window you need to select a
database name from the dropdown and then based on choice you can check “Table” and/or
“Views” checkbox to see tables and/or views in the list box below, on the left. If you click any
table or view name in the left table you will see its column names in the list box, on the right.
Finally, in the text box below, you can write your select query or sub query with join etc. and the
results of the query will be loaded in the data grid of the BlueSky Statistics application.

Select a database: | postgres -

Check Tables/Views to see the list of Tables/Views, Click on Displays the columns of the selected table.
the tablefview name to see its colurnns on the right pane

Table and Column(s) Selector Window “

Tables\Visws: Tables |:| Views Columns:
test preduct_no
preducts * name

price

Write your 'SELECT' query in the textbox below. You can enter complex gueries, sub-gueries, joins as supparted by your SGL
SErVer.

1. M5-50L Example: SELECT * FROM Owner.TABLE-NAME
2. MySQL / Postgres / M5-ACCESS Example:  SELECT * FROM TABLE-MAME

select * from products

|Back|‘{}K‘

3. Click ‘OK’ to load the result of select query in the BlueSky Statistics grid.



Configure MySQL and Import MySQL data into BlueSky Statistics

Contact MySQL server admin to get “host” address, user id and password of MySQL server.

1. Connection step are similar to MS-SQL connection steps. Enter MySQL server name, user id and

password.

Data Source Selector Window n

Select Data Source:

MSS0L
Pastgre50L
Cracle

[ MySQL
SQLite
MS-ACCESS

Specify Connection Parameters:

Host / Server: localhost
User |D: root
Paszwaord:

Cancel Connect




2. Click “Connect” button and you will see following window. In this window you need to select a
database name from the dropdown and then based on choice you can check “Table” and/or
“Views” checkbox to see tables and/or views in the list box below, on the left. If you click any
table or view name in the left table you will see its column names in the list box, on the right.
Finally, in the text box below, you can write your select query or sub query with join etc. and the
results of the query will be loaded in the data grid of the BlueSky Statistics application.

] Table and Column(s) Selector Window “
Select a database: | mysgl =
Check Tables/Views to see the list of Tables/Views, Click on Displays the columns of the selected table.

the tablefview name to see its colurnns on the right pane

Tables/Views: Tables [ ] Views Columns:

e - o ‘
clave_master_info
slave_relay_log_info User
slave_worker_info Password
slow_log Select_priv
tables_priv Insert_priv
time_zone Update_priv
time_zone_leap_second Delete_priv
time_zons_name Create_priv
time_zone_transition Drop_priv
time_zone_transition_type Reload_priv

v Shutdown_priv

user . P .

Write your 'SELECT' query in the textbox below. You can enter complex gueries, sub-gueries, joins as supparted by your SGL
SErVer.

1. M5-50L Example: SELECT * FROM Owner.TABLE-NAME
2. MySQL / Postgres / M5-ACCESS Example:  SELECT * FROM TABLE-MAME

zelect * from user

|Back|‘{}K‘

3. Click ‘OK’ to load the result of select query in the BlueSky Statistics grid.



